I can't find where I read it, but I remember coming across something that suggested it is better to access height of CGRect
s using CGRectGetHeight(rect)
instead of accessing the variable via rect.size.height
CGFloat height = CGRectGetHeight(self.frame);
// vs
CGFloat height = self.frame.size.height;
Most of the time, this has to do with views in my use, and I was wondering if there is a real difference (apart from syntax) that separates these two lines of code.
If one is preferential over the other, an explanation of why would be great!