In this example, the "new" adjective can and should be converted to an absolute date but this does not answer the general problem, where that is not always possible.
Semantically, adjectives always represent unary relationships, different from verbs which can be unary ("Bob runs."), binary ("Bob runs to Alice.") or more ("Bob runs to Alice with Trudy."). This is confusing in English, because syntactically, adjectives are sometimes used in an unary ("new car") but other times in a binary ("The car is new.") way. In other languages, such as Russian, that is not the case, you would just say "Car new." (translated of course).
Now, mathematically, an unary relation can be seen as a set and the other way around. Thus, the most adequate RDF formalism would be, as @reto-gmür said, membership of a class "NewThing", as classes are sets of individuals. As RDF uses binary relations, we need, as sometimes in English, the helper relation "a".
However, while sets and unary relations can be seen as mathematically equivalent, and there is even a third equivalent formalism, a function to [0,1], there is a difference in emphasis.
Thus, in some cases it may be more appropriate to use a property with a boolean range like this:
:BobsCar :isNew "true"^^xsd:boolean.
or
:BobsCar :newness "true"^^xsd:boolean.
(both property names are a bit awkward). I did not see this last modelling variant very often, however, except when modelling statistical data using the RDF Data Cube vocabulary.
I think this last way of modelling is less useful for instance data and more for ontologies because you can define:
:newness rdfs:domain :Car; rdfs:range xsd:boolean.
whereas
:Car rdfs:subClassOf [owl:unionOf (:NewThings :OldThings)].
requires OWL and is more complex, so that I expect it to be less supported by reasoners. Still, class membership looks more elegant and in line with the RDF philosophy to me, so I would recommend that in most cases.