Currently in my Makefile
I have:
prefix ?= /usr/local
So that I can override prefix
value when calling make
, like in the following:
make prefix="/new_path"
My question is: does a convention exist for naming this variable inside a Makefile, especially do I have to call it prefix
or PREFIX
?
This matter since lower or upper case matters in this situation!
Note that I do not use autotools
, just a "simple" Makefile